Решаем задачу с помощью инструмента «писк решений».

Введение.

Цель контрольной работы: Получение практических навыков оптимального задач планирования и автоматизации анализа ресурсов.

Задача контрольной работы: Выяснить оптимальный замысел поставки товара на оптовые базы при минимальных суммарных транспортных издержках.

Ответ.

Исходные параметры модели

n – 4 – количество фирм-представителей.

m – 5 – количество потребителей – оптовых баз.

a¡ — ежемесячные количества предложения продукции (i=1.4) [шт]

– спрос на продукцию (емкость оптовых баз) (i=1,5) [шт]

— затраты на поставку и производство продукции от представителей на оптовые базы потребителя [руб/шт.]

больше (суммарное предложение больше суммарного спроса)

либо меньше (суммарное предложение меньше суммарного спроса)

либо равняется (суммарное предложение равняется суммарному спросу, сбалансированная модель).

Исходные параметры модели

– количество продукции, транспортируемой из пункта отправления и пункт назначения [шт]

целевая функция – транспортные затраты на перевозку всей продукции [руб.]

Экономико-математическая модель

f(X)= cij xij min,

xij = ai , i = 1,m,

xij = bj , j = 1,n,

xij ? 0 , j = 1,n.

Таблица №1. Параметры перевозок от представителей к оптовым базам.

Пояснительная записка

Главная часть

Обрисовываем транспортной задачи.

Исходные параметры модели

n – 4 – количество фирм-представителей.

m – 5 – количество потребителей – оптовых баз. a¡ — ежемесячные количества предложения продукции (i=1.4) [шт]

– спрос на продукцию (емкость оптовых баз) (i=1,5) [шт]

— затраты на поставку и производство продукции от представителей на оптовые базы потребителя [руб/шт.]

больше

Искомые параметры модели

– количество продукции, транспортируемой из пункта отправления и пункт назначения [шт]

транспортные затраты на перевозку всей продукции [руб.]

Создаем экранную форму, вводим условия задачи, зависимости и исходные данные.

Экранная форма

Объект математической модели Выражение в Excel
Формула в целевой ячейке Н15 =СУММПРОИЗВ(С3:G6$C12:G15)
Ограничения по строчкам в ячейках Н3; Н4; Н5; Н6. = СУММ(C3:G3) =СУММ(C4:G4) =СУММ(C5:G5) =СУММ(C6:G6)
Ограничения по столбцам С7; D7; E7; F7; G7. =СУММ(C3:C6) =СУМ(D3:D6) =СУММ(E3:E6) =СУММ(F3:F6) =СУММ(G3:G6)
потребности и Суммарные запасы в ячейках J8; I9. =СУММ(J3:J7) =СУММ(C9:H9)
Проверка баланса в ячейке J9 =В случае если (I9=J8;”БАЛАНС”;В случае если;I9J8;”ПРЕДЛОЖЕНИЕ БОЛЬШЕ”;”ЗАПАСЫ БОЛЬШЕ”))

Задание.

На пять оптовых баз поставляется продукция от четырех представителей. Ежемесячное предложение продукции представителями (шт.), емкость оптовых баз (шт.) и тарифы (руб./шт.) за доставку продукции от представителей к оптовым базам приведены в таблице №1. Решить задачу определения транспортного замысла поставки данного товара на оптовые базы так, дабы суммарные транспортные издержки были минимальны.

Параметры перевозок от представителей к оптовым базам.

Тарифы,руб/шт. Оптовая база 1 Оптовая база2 Оптовая база 3 Оптовая база 4 Оптовая база 5 Предложение, шт.
Представитель 1
Представитель 2
Представитель3
Представитель4
Емкость шт.

Решаем задачу посредством инструмента «Писк ответов».

Установить курсор в поле «Установить целевую ячейку»

Ввести адрес целевой ячейки ( надавили левой клавишей мыши на целевую ячейку в экранной форме).

Ввели направление оптимизации ЦФ (щелкнув 1 раз левой клавиши мыши по секторной кнопке «минимальному значению»

В окне «Поиск ответа» в поле «трансформации ячейки» впишем адреса

Нужные адреса возможно вносить в поле «изменяя ячейки» и машинально методом выделения мышью соответствующих ячеек переменных конкретно в экранной форме.

Ввести ограничения модели. В нашем случае на значения переменных накладывается граничное условие равенства.

Надавили кнопку «параметры» и заполнили кое-какие поля окна «параметры поиска ответа»

По окончании запуска ответа показалось «поиск ответа». На данном сообщении продемонстрировано что поиск не имеет возможности отыскать подходящего ответа.

По окончании того как мы надавили кнопку выполнить, мы приобретаем ответ на данную задачу.

Заключение

Итог ответа: Емкость оптовых баз больше предложений поставщиков. В данных условиях нереально выяснить оптимальный замысел поставки товара на оптовые базы.

Вывод: Дабы удовлетворить потребности оптовых баз нужно привлечь дополнительных поставщиков с фирм-представителей чтобы поделить транспортные издержки и сделать их минимальными. Или совсем отказаться от собственных поставок и воспользоваться услугами сторонних транспортных компаний.

Перечень литературы.

1. Должнеков В.А., Колесников Ю.В. Микрософт Excel 2003. – СПб.:ИНV Спб,2006

2. Мак-Федрис П\ функции и Формулы в MicrosostExcel2003. – М.:Вильямс,2006

3. Информационные совокупности в экономике: практикум / кол. Авторов по общ.ред.П.В.Аникина. – М.: КНОРУС,2008

Ответ задачи о распределении ресурсов посредством Поиска ответов


Также читать:

Понравилась статья? Поделиться с друзьями: