Решение транспортной задачи с помощью надстройки excel поиск решения

Задание данных

На странице окна Excel выстройте исходную таблицу, как продемонстрировано на рис. 3.1. Ячейки с адресами В2:Е5 резервируются для переменных задачи – это изменяемые ячейки. В ячейках А8:A11 заносятся запасы грузов в пунктах отправления, включая и фиктивный, в ячейках B12:E12 заносятся потребности (спрос) в грузах в пунктах назначения. По окончании занесения в ячейку числа либо формулы нужно надавить клавишу ENTER.

Рис. 3.1. Фрагмент страницы рабочей книги с исходными данными

В ячейки с адресами В8:Е11 занесены коэффициенты матрицы затрат на перевозку грузовтранспортные тарифы. Четвертая строка данной матрицы соответствует перевозкам от фиктивного поставщика.

Ячейки А2:А5 содержат формулы для расчета ограничений (1) – (4). Формула ограничения (1) занесена в ячейку А2 и имеет форму =СУММ(B2:E2). Соответственно ограничения (2), (3) и (4) занесены в ячейки А3, А4 и А5 в виде формул =СУММ(B3:E3), =СУММ(B4:E4) и =СУММ(B5:E5).

В ячейках В6:Е6 находятся формулы ограничений (5)–(8), каковые соответственно имеют вид: =СУММ(B2:B5), =СУММ(C2:C5), =СУММ(D2:D5), =СУММ(E2:E5).

Формула для расчета целевой функции (9) занесена в ячейку В14 и имеет форму: =СУММПРОИЗВ(B2:E5;B8:E11). В эту же ячейку будет занесено вычисленное оптимальное значение целевой функции.

Ответ задачи

Поставить курсор мыши в ячейку В14, в которой будет находиться вычисленное значение целевой функции, и надавить на левую кнопку мыши.

Войти в меню Сервис, выбрать в нем Поиск ответа и щелкнуть на нем левой кнопкой мыши. На экране покажется диалоговое окно Поиск ответа (рис. 3.2).

Рис. 3.2. Диалоговое окно Поиск ответа с внесенными ограничениями

В поле Установить целевую ячейку заносится $В$14. Для этого несложнее всего установить курсор мыши вовнутрь ячейки, щелкнуть в ней левой кнопкой мыши, после этого щелкнуть мышью на ячейке В14.

Потому, что ищется минимум целевой функции, то по окончании слова Равной выделим Минимальному значению, щелкнув в соответствующем кружочке мышью.

В поле Изменяя ячейки занесем диапазон $B$2:$Е$5, так как эти ячейки отведены под значения вычисляемых переменных. Для этого поставим курсор в поле Изменяя ячейки, после этого поставим курсор на ячейке В2 и при надавленной левой кнопке мыши переведем курсор на ячейку Е5. В поле Изменяя ячейки покажется нужный диапазон ячеек.

В поле Ограничения занесем ограничения (1)–(8). Для этого щелкнем мышью на кнопке Добавить. Покажется диалоговое окно Добавление ограничения (рис. 3.3).

Рис. 3.3. Диалоговое окно Добавление ограничения

К примеру, второе ограничение занесено следующим образом: в окне Поиск ответа щелкнуть на кнопке Добавить. Откроется диалоговое окно Добавление ограничения. В поле Ссылка на ячейку поставить курсор мыши надавить на левую ее кнопку. После этого поставить курсор мыши на ячейку В6, где введено ограничение и при надавленной кнопке мыши совершить впредь до ячейки с адресом Е6. В среднем поле окна Добавить ограничения выбираем символ равенства, а в последнем поле обрисованным выше методом заносим ячейки В12:Е12, спрос потребителей. Подобно заносятся другие ограничения.

В поле Поиск ответа (рис.3.2) щелкнуть мышью на кнопке Параметры. На экране покажется диалоговое окно Параметры поиска ответа(рис. 3.4).

Рис. 3.4. Диалоговое окно Параметры поиска ответа

В этом окне устанавливаются параметры поиска ответа. Тут отметить квадратикиЛинейная модель, Неотрицательные значения, Автоматическое масштабирование. Щелкнуть на кнопке ОК.

Опять попадаем в диалоговое окно Поиск ответа. В этом окне (рис.3.2) щелкнем левой кнопкой мыши на кнопку Выполнить. На экран выводится окно Результаты поиска ответа. Дабы сохранить полученное ответ, нужно левой кнопкой мыши надавить сперва на кружок Сохранить отысканное ответ,а после этого на кнопку ОК.

В один момент на Странице экрана кроме этого появляются результаты ответа задачи (рис.3.5): в столбце А2:A5 и строке B6:E6 выводятся вычисленные значенияограничений.

Рис. 3.5. Окно с результатами ответа задачи

В ячейках В2:Е5 находятся вычисленные значения переменных – количеств перевозок от каждого пункта отправления к каждому пункту назначения. В ячейке с целевой функцией В14 – вычисленное значение целевой функции.

Так, отысканное оптимальное ответ имеет форму:Fmin = 5200, x11 = 0, x12 = 0, x13= 300, x14 = 300, x21 = 200, x22= 600, x23 = 0, x24 =0, x31 = 700, x32= 0, x33 = 0, x34= 300, и фиктивные переменные x41 = x42 = x44= 0, x43= 500.

Замечание. Перед тем как приступать к ответу транспортной задачи данного варианта, нужно проверить баланс между неспециализированным запасом груза у поставщиков и неспециализированной потребностью у потребителей. В случае если соответствующие суммы не равны между собой, нужно ввести или фиктивного поставщика, или фиктивного потребителя.

Личные задания:

Вариант № 1

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Склад Магазины — клиенты Запасы на складе (ед. прод.)
“Анна” “Вада” “Ева” “Алла” “Мех”
“Таганка”
“ВВЦ”
“Щёлково”
“Коньково”
Количество заказа

Вариант № 2

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Магазин Склад Магазины — клиенты Запасы на складе (ед. продук- ции)
Росстек Шер Ткани Мода Вита
Иваново
Москва
Новгород
Серпухов
Количество заказа (ед.прод)

Вариант № 3

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Магазин Склад Магазины — клиенты Запасы на складе (ед. прод.)
“Всё для дома” “Здоро- вый сон” “Фея” “Ночное царство” “Мех”
“Вороново”
“Фили”
“Беляево”
“Выхино”
Количество заказа (ед.прод)

Вариант № 4

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Склад Магазины — клиенты Запасы на складе (ед.прод.)
ВДНХ Юго- Западная Фили Арбат- ская Соколь- ники
Пролетарская
Митино
Строгино
Количество заказа (ед.прод)

Вариант № 5

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Склад Магазины — клиенты Запасы на складе (ед.прод.)
Тверь Рязань Тула Чехов
Москва
Петербург
Саратов
Самара
Количество заказа

Вариант № 6

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Склад Магазины — клиенты Запасы на складе (ед.прод.)
Сокол Рижская ВДНХ Киевская Царицыно
Пражская
Волжская
Курская
Савёловская
Количество заказа

Вариант № 7

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Склад Магазины — клиенты Запасы на складе (ед.прод.)
Новгород Москва Самара Саратов Тверь
Нижний Новгород 0,5
Саратов 0,5
Самара 0,5
Петербург 4,5
Количество заказа

Вариант № 8

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Склад Магазины — клиенты Запасы на складе (ед.прод.)
“Колбасы” “Мясо” “Мясные деликатесы” “Дина”
Черкизово 0,5
Царицыно
Бородино 2,5
Вешняки 1,5
Количество заказа (ед.прод)

Вариант № 9

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Склад Магазины — клиенты Запасы на складе (ед. прод.)
“Булочная” “Хлеб” “Сла- дости” “Сдоба” “Сладко- ежка”
“Крекер” 2,5 1,5
“Славянка” 3,5 1,6
“Сластёна” 2,5
Количество заказа (ед.прод)

Вариант № 10

Нужно решить транспортную задачу: минимизировать затраты на доставку продукции клиентам со складов компании, учитывая следующие затраты на доставку одной единицы продукции, количество продукции и объём заказа, хранящейся на каждом складе:

Склад Магазины — клиенты Запасы на складе (ед. прод.)
“Диана” Прага и “ГУМ” “Елена”
“Перово” 1,5
“Волжская”
“Пражская” 2,5 3,5
“Беговая” 3,5 1,5
Количество заказа (ед.прод)

Ответ транспортной задачи при помощи надстройки Поиск ответа


Также читать:

Понравилась статья? Поделиться с друзьями: